Request for new tagged release to support CMake 4 #78

Open
opened 2025-04-02 04:11:14 -05:00 by mikaellindemann · 0 comments
mikaellindemann commented 2025-04-02 04:11:14 -05:00 (Migrated from github.com)

With the release of CMake 4.0.0 it refuses to configure projects that do not announce a minimum required version of version 3.5 or higher.

The currently tagged release of this repository is 0.2 that has a minimum required version of 2.8.5.
However, the master branch has been updated to 3.13 which is supported by CMake 4.0.0.

I am consuming the library through vcpkg, that has a preference for tagged releases only.

Is it possible to tag a new release from the current master branch?

With the release of CMake 4.0.0 it refuses to configure projects that do not announce a minimum required version of version 3.5 or higher. The currently tagged release of this repository is 0.2 that has a minimum required version of 2.8.5. However, the master branch has been updated to 3.13 which is supported by CMake 4.0.0. I am consuming the library through vcpkg, that has a preference for tagged releases only. Is it possible to tag a new release from the current master branch?
Sign in to join this conversation.
No milestone
No assignees
1 participant
Notifications
Due date
The due date is invalid or out of range. Please use the format "yyyy-mm-dd".

No due date set.

Dependencies

No dependencies set

Reference
gh-tplgy/cppcodec#78
No description provided.