Upgrade minimum rust version #230

Closed
opened 2018-05-17 22:09:10 -05:00 by kinggoesgaming · 7 comments
kinggoesgaming commented 2018-05-17 22:09:10 -05:00 (Migrated from github.com)

#143 set the minimum rust version to 1.18.0. I think its time we start on bumping the version

Tasks to do:

  • Check all the dependent crates' minimum rust versions.
    • Eliminate all crates that crates that don't specify a minimum version.
  • Eliminate crates that have not yet reached 1.0
  • Determine path of upgrade
#143 set the minimum rust version to `1.18.0`. I think its time we start on bumping the version Tasks to do: * [ ] Check all the dependent crates' minimum rust versions. * Eliminate all crates that crates that don't specify a minimum version. * [ ] Eliminate crates that have not yet reached `1.0` * [ ] Determine path of upgrade
Dylan-DPC-zz commented 2018-05-18 01:04:39 -05:00 (Migrated from github.com)

Eliminate crates that have not yet reached 1.0

Is there a reason for this? I think it is fine to depend on crates that haven't reached 1.0. It is a good rule but we shouldn't be strict on it.

> Eliminate crates that have not yet reached 1.0 Is there a reason for this? I think it is fine to depend on crates that haven't reached 1.0. It is a good rule but we shouldn't be strict on it.
KodrAus commented 2018-05-20 16:36:12 -05:00 (Migrated from github.com)

@Dylan-DPC I think this is part of a process for figuring out what the minimum versions of dependents of uuid are.

As for our minimum version policy, I think it makes sense to be conservative, since uuid is widely depended on. So for uuid with just v1, v3, v4, v5 features we should probably target the lowest version we can and stick with it. We've got feature gates for newer things so dependents can opt in to more recent compilers.

@Dylan-DPC I think this is part of a process for figuring out what the minimum versions of dependents of `uuid` are. As for our minimum version policy, I think it makes sense to be conservative, since `uuid` is widely depended on. So for `uuid` with just `v1`, `v3`, `v4`, `v5` features we should probably target the lowest version we can and stick with it. We've got feature gates for newer things so dependents can opt in to more recent compilers.
kinggoesgaming commented 2018-05-21 15:24:56 -05:00 (Migrated from github.com)
Particular issue of interest: rust-lang-nursery/api-guidelines#123. Also https://github.com/rust-lang-nursery/api-guidelines/issues/123#issuecomment-390456962
Dylan-DPC-zz commented 2018-05-22 06:22:08 -05:00 (Migrated from github.com)

We need to bump the msvr to 1.22.0 as in the new release of rand (0.5) they are using "break with a value" feature which was introduced in 1.22.0 (and is the msvr for rand crate).

We need to bump the msvr to 1.22.0 as in the new release of `rand` (0.5) they are using "break with a value" feature which was introduced in 1.22.0 (and is the msvr for rand crate).
KodrAus commented 2018-05-23 01:40:10 -05:00 (Migrated from github.com)

Bumping to 1.22 seems reasonable to me, it should be accessible to most folks through package managers. We might want to wait until the next breaking release of uuid though since it's pretty widely used.

Bumping to `1.22` seems reasonable to me, it should be accessible to most folks through package managers. We might want to wait until the next breaking release of `uuid` though since it's pretty widely used.
Dylan-DPC-zz commented 2018-05-23 08:32:30 -05:00 (Migrated from github.com)

@KodrAus yah that's the plan to update it for 0.7.0 release

@KodrAus yah that's the plan to update it for 0.7.0 release
kinggoesgaming commented 2018-05-29 12:38:02 -05:00 (Migrated from github.com)
#254
Sign in to join this conversation.
No milestone
No assignees
1 participant
Notifications
Due date
The due date is invalid or out of range. Please use the format "yyyy-mm-dd".

No due date set.

Dependencies

No dependencies set

Reference
gh-uuid-rs/uuid#230
No description provided.